DFW Mustang Forums banner
1 - 17 of 17 Posts

·
KEK
Joined
·
4,422 Posts
Discussion Starter · #1 ·
alright, i'm not too good in the engine department..but damn my shit stinks when i get on it. i got a 98 GT and i've had it for about 7 months now, and only in about the recent month i've been smelling this raunchy ass smell everytime i really get on it, dropping it into 1st and punching it and running it up to about 45k or so. everytime i run someone (and beat them of course:p), they always ask what the hell that stinky ass smell is. i dunno what the hell it is..i figured i'd ask some of you because right now i don't have the money to run it up to a shop or anything. and also i haven't noticed any leaking of anything and the oil is clean, full and fresh. any suggestions on what it is?
 

·
Registered
Joined
·
70 Posts
f0ur sixer said:
alright, i'm not too good in the engine department..but damn my shit stinks when i get on it. i got a 98 GT and i've had it for about 7 months now, and only in about the recent month i've been smelling this raunchy ass smell everytime i really get on it, dropping it into 1st and punching it and running it up to about 45k or so. everytime i run someone (and beat them of course:p), they always ask what the hell that stinky ass smell is. i dunno what the hell it is..i figured i'd ask some of you because right now i don't have the money to run it up to a shop or anything. and also i haven't noticed any leaking of anything and the oil is clean, full and fresh. any suggestions on what it is?
could you be a little bit more specific? as in what does it smell like(as best as you can determine anyway)

does it happen only in low gears or anytime you go high in the rpm? I'm assuming you meant 4.5k and above
 

·
KEK
Joined
·
4,422 Posts
Discussion Starter · #3 ·
specific? lol..let's just say it smells like ass, like raw eggs or something. yeah, around 4k+. it's an auto, and i can just be in drive going about 30 and punch it..and you can start to smell it. i've had some friends follow me before and they say they can smell it everytime i get on it..and in the cab of the car..it gets pretty bad..cause i have to roll the windows down. so lately i've been laying off the high speeds an such, cause i don't have the money to send it anywhere..i'm just trying to get an idea of what it is so when i DO take it to the shop..they wont charge me for seeing what's wrong with it, if you know what i'm sayin
 

·
IA2
Joined
·
22,150 Posts
Pull the tranny dipstick and see what color the fluid is. Does it smell like burned toast, and is it dark? Tranny could be slipping.

When the AOD in my F150 started to go I could smell it pretty good in the cab.

Another thing to look for a road debris melted onto your exhaust system that starts to melt/burn when you get on it.
 

·
Registered
Joined
·
70 Posts
mikeb said:
Pull the tranny dipstick and see what color the fluid is. Does it smell like burned toast, and is it dark? Tranny could be slipping.

When the AOD in my F150 started to go I could smell it pretty good in the cab.
yeah, thats pretty much what i was gonna say.. the only other thing i can think of that would create a smell would be the cats.. but from what you've said so far that doesnt make a whole lot of sense..

check the fluid and get back to us
 

·
KEK
Joined
·
4,422 Posts
Discussion Starter · #6 ·
nah, not burnt toast..more like, a trip to the pot after some mexican food. alright, thanks, i'll check it when i get some daylight. but also i do have a new MAC h-pipe with hi-flo cats that i had put on about 3 months ago, i don't see why it would be causing the smell after 2 months or so..
 

·
Registered
Joined
·
70 Posts
f0ur sixer said:
nah, not burnt toast..more like, a trip to the pot after some mexican food. alright, thanks, i'll check it when i get some daylight. but also i do have a new MAC h-pipe with hi-flo cats that i had put on about 3 months ago, i don't see why it would be causing the smell after 2 months or so..
well as far as the cats go.. ive seen it in old stuff.. and new stuff if the stickers werent removed from the pipes etc, but if your stuff is new then its doubtfull thats what it is..

anything is possible, but when daylight hits take a look and see whats going on
 

·
KEK
Joined
·
4,422 Posts
Discussion Starter · #10 ·
nope, i made sure there wasn't any type of stickers or decals on it before it was put on. alright then, i appreciate it, and i'll take a look and see what's going on in there later on today. again, thanks
-kenny
 

·
Registered
Joined
·
655 Posts
most likely the cats.
 

·
Formerly 5.0Vert
Joined
·
9,515 Posts
after a good night's sleep(well, more than 5 hours,:( ) i have come to the conclusion that you should check your cats first and if it is not them then check the tranny,

can anyone answer me this?
when i jack up my car(which had a pole go halfway through it, through the driver's seat) it leaks tranny fluid!:confused: :confused: :confused: anyone know why?
 

·
Registered
Joined
·
655 Posts
does it matter what brand o2's?
 

·
Registered
Joined
·
797 Posts
I'm voting for the cats. Specifically, it sounds like they're partially clogged. A good way to check this is with a vacuum gauge. If you run the engine with the gauge attached, you will see the vacuum gradually lower as the car runs. This will occur when there is a blockage in the exhaust. The vacuum should stay steady in the upper teen's if it's ok. Try revving the engine (not excessively) and then dropping back to idle as part of the test, since higher RPM will put more air into the exhaust.

If your car is even remotely new, then the cats should be covered. I think it's something like 100K miles on the cats per federal mandate.

Do you always get your gas at the same place? If so, try a different type and see if helps. It might take a couple tanks, but I've heard that contaminants in the cats will burn off if the blockage isn't too bad.

I haven't seen a $25 O2 sensor before. More like 2-3 times that.
 

·
KEK
Joined
·
4,422 Posts
Discussion Starter · #17 ·
i've tried like 5-6 different stations..when i first bought the car i was putting in unleaded..but now all i ever put in is 93..but the car was doing it while running on regular unleaded also. i haven't able to look at the tranny fluid either, i've been caught up in working. sunday is my next day off, so i'll try and get a look then. right now i don't have the money to get new o2 sensors, i barely have enough to put gas in it, i'm down to the change scroungin level..where i pay the clerks at the stations in pennies and nickels..the next time i'll be able to get "spending" money is when tax return comes..so it's gonna be a good while. thanks all for your help..it's all done me a good deal.
-kenny
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top