DFW 'Stang Forums banner

1 - 5 of 5 Posts

·
drvng fstr thn u w/1 hand
Joined
·
2,755 Posts
Discussion Starter #1
For some reason on my '04 Cobra my damn wheel studs keep snapping.
The shoes I have on are CCW 3 piece classic 17x10.5 in the rear. ON those I have the BFG 315/35s. For some reason I have snapped 3 wheels studs on it. Not all at the same time... For instance I stopped at the gym today and noticed another one had broken off.
Anyone know the reason for this or have had this problem on thiers?

I'm really starting to think I should be pretty concerned...
:confused:
 

·
UNFUCKWITHABLE
Joined
·
12,482 Posts
Do you have the correct lugs for those wheels?

Different wheels have different lug seats, and can require different lug nuts... If you use the wrong ones you can get inaccuarate torque readings, etc.

BTW, when you put the lugs on how tight are you putting them? With stock studs the lugs nuts should be torqued to 100 ft-lbs.
 

·
drvng fstr thn u w/1 hand
Joined
·
2,755 Posts
Discussion Starter #4
They were stock studs with stock lugs. I didn't have to change the lugs with the rims i got. So everything is right. They weren't cross threaded..and they were torqued to their correct torque specs..I'll just be driving around and after a few days a stud will be snapped! So far, its only been the stock studs that have been snapping, not the ones I have replaced them with.
 

·
Registered
Joined
·
334 Posts
Well there is an easy fix...Reduce horespower and lead foot....j/k :D
 
1 - 5 of 5 Posts
Top