DFW Mustang Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
802 Posts
Discussion Starter #1 (Edited)
I bought me a 88 GT Stang V8 5.0 5 spd around 5 or 6 months ago, the problem i am having is that when the car is idle there is this rattle sound to it, if i lightly touch the clutch it dissapears, but if i let go it, its back, same thing while i am driving, if i am barly touching it, the rattle dissapears, and if i dont touch it at all, it comes back, i already changed the pilot bearing and also the bearing that spins, and i am still getting that sound. Has anyone heard of this happending to their car? I would really apreciate any help you guys give me. Thanks
 

·
Fear the lawn gnome
Joined
·
4,535 Posts
tighten the cable a tad if its an adjustable cable. i had mine come loose aftermarket one. the bolts backed off put it had a little play up top and the damn peddle would rattle.
 

·
Registered
Joined
·
802 Posts
Discussion Starter #3
i am almost 100% sure the peddle isnt rattleing, the sound is sort of like a little metal bell doing ding ding ding ding ding........
 

·
Premium Member
Joined
·
1,152 Posts
Probably your throwout bearing. Did you grease it up good? You know the bearing that spins. I had this same problem and I just got an adjustable cable and tighten it to where there was no slack.
 

·
Premium Member
Joined
·
2,661 Posts
Damn I am having the exact same problem! I still have factory quad/cable.... im changing my shit this weekend!!!:D
 

·
Registered
Joined
·
802 Posts
Discussion Starter #9
i guess i am going to get an ajustable cable for my clutch, its very annoying. Wheres a good website or place to go get a clutch cable? I am in Dallas. Thanks
 
1 - 11 of 11 Posts
Top