DFW Mustang Forums banner
1 - 8 of 8 Posts

·
OLD SCHOOL crew
Joined
·
11,186 Posts
Discussion Starter · #1 ·
I have fuel pressure at the schrader valve, but the car doesn't even hiccup. I have cranked and cranked it, but there is no fuel on the plugs. I have spark. What's the deal?

Could a bad ignition switch send a signal to the computer to keep the injectors from coming on?
 

·
World Record Holder!
Joined
·
11,061 Posts
Did you take the distributor out for any reason? If you haven't touched it since the last time it was running, it could be the fuel pump, fuel pump relay, fuel pump fuse or the computer.

EDIT: I just reread your post. If you have spark, it may be that the ground is loose. It's an orange wire bolted to the back of the driver's side head.
 

·
Highly Compressed
Joined
·
2,386 Posts
It could be the fuel pump, fuel pump relay, fuel pump fuse or the computer.
It could be the wiring to the injectors (computer) I'll give him that one.... Its doubtful that its the fuel pump, relay or fuse since you do have pressure. If it were your fuel pump you wouldn't see any fuel pressure at all or the car would fire up, idle a few moments....then die. If its the computer, the injectors won't open...ie no spray. It could also be a plugged/frozen fuel pressure regulator. Its doubtful that all 8 of your injectors are plugged. Get yourself a voltmeter and pull one of the injector connectors and test for voltage (intermittent) while someone cranks the engine......I not sure about the potential for it being the ignition switch.....
 

·
OLD SCHOOL crew
Joined
·
11,186 Posts
Discussion Starter · #4 ·
The ground is there...gonna get the volt meter and test the injectors...
 

·
Worship me
Joined
·
34,275 Posts
Make sure that ground is good on the back of the head, test it. If its not a good enough ground the injectors will never open.
 

·
Premium Member
Joined
·
4,175 Posts
Hey Hobie,

If you figure that sh*t out post up what's wrong and all because my car is doing sort of the same thing.

Hey guys, where is the fuel pump relay and fuse? Just want to check mine because I'm having these problems. Could you also tell me if the relay got hot then would the fuel pump come on but not put enough pressure through, etc.
 

·
OLD SCHOOL crew
Joined
·
11,186 Posts
Discussion Starter · #8 ·
stangcrazy said:
Hey Hobie,

If you figure that sh*t out post up what's wrong and all because my car is doing sort of the same thing.

Hey guys, where is the fuel pump relay and fuse? Just want to check mine because I'm having these problems. Could you also tell me if the relay got hot then would the fuel pump come on but not put enough pressure through, etc.
Fuel pump relay is under the driver's seat.
I sprayed a fairly big dry shot with the same tune for a LONG time. Once I got it dialed it was the same tune basically for two years. Then it started burning plugs. No tuning would stop it. Then the car started acting like it was running out of gas. I bought two new(purchased two in a row, not ran them at the same time) 255lph fuel pumps and my car promptly turned them into junk. Put the 155 back in (came with car) and it would run, but would act like it was running out of gas if driven over an hour or so. Fuel pressure was lower than normal and would drop off after an hour...I just put a new relay in a couple days ago (old one appeared fine) and the fuel pressure is back up there.

Does this sound like what your car is doing? I have had mine down FOREVER and haven't gotten it started yet, but the fuel pressure is better with the new relay, it barely came out of the schrader with the old one, it spews out with the new one :D
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top