DFW Mustang Forums banner
1 - 6 of 6 Posts

· Registered
Joined
·
655 Posts
Discussion Starter · #1 ·
i was trying to race this accord that i knew i could take and when the light changed i took off annd then the car died! it was like it flooded. it was full of gas, has a new filter and 225 pump, plugs wires cap and rotor and msd coil. full tank too. also it wouldn't start at first today, it just clicked slowly like it was dead and then after like 30-40 seconds i tcranked. any help is very appreciated. thanks all.
 

· Registered
Joined
·
655 Posts
Discussion Starter · #3 ·
yes ttt. and sorry, it is a 95 5.0 vert. seems electrical but i know very little about that stuff. like i said though, it did eventually crank. should i try new mass air and 24-30 inj.? will that give me any diff. in power o fshould i just wait. the reason i ask is the new pump. should i get a new fuel pressure regulator? is so what brand?
 

· Registered
Joined
·
655 Posts
Discussion Starter · #4 ·
$8.00 negative battery cable grounded t othe anti roll bar fixed the problem! thanks guys!:) :) :) :cool:
 

· Registered
Joined
·
655 Posts
Discussion Starter · #6 ·
got dead in the road so i poped the hood and started wiggling everything loose but that.......then felt it and was like YOU B*STARD! YOUR ARE OUT OF THIS STANG FOREVER! then pleaded for it to work long enough to get me to autozone. then KIKED HIS A** OUT!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top