Need MS-DOS Defragment Program - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 05-05-2003, 10:38 AM Thread Starter
BELIEVE, IT'S TIME!!!!
 
Who Needs 8's Avatar
 
Join Date: Mar 2001
Location: A little here, a little there . . .
Posts: 14,997
Exclamation Need MS-DOS Defragment Program

I tried running defrag from Windows and it keeps restarting because it says "drive information has changed" to the point where it's getting nothing done because it keeps restarting

Does anyone have or know where I can get a program that I can put on a bootable floppy so I can run defragment from dos. I used to do this all the time a long time ago, but I don't have the program anymore.
Who Needs 8 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-05-2003, 10:49 AM
\(_o)/
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
MSDOS had a program called defrag as well, do a google search for it.
AbecX is offline  
post #3 of 9 (permalink) Old 05-05-2003, 10:51 AM
 
Join Date: Oct 2001
Posts: 1,245
Re: Need MS-DOS Defragment Program

Quote:
Originally posted by Who Needs 8
I tried running defrag from Windows and it keeps restarting because it says "drive information has changed" to the point where it's getting nothing done because it keeps restarting

Does anyone have or know where I can get a program that I can put on a bootable floppy so I can run defragment from dos. I used to do this all the time a long time ago, but I don't have the program anymore.
If you have any Anti-virus or Firewall programs running it will cause that error. By stopping these you should be able to run the defrag from windows.
Oxidizer187 is offline  
 
post #4 of 9 (permalink) Old 05-05-2003, 11:03 AM Thread Starter
BELIEVE, IT'S TIME!!!!
 
Who Needs 8's Avatar
 
Join Date: Mar 2001
Location: A little here, a little there . . .
Posts: 14,997
Re: Re: Need MS-DOS Defragment Program

Quote:
Originally posted by Oxidizer187
If you have any Anti-virus or Firewall programs running it will cause that error. By stopping these you should be able to run the defrag from windows.
Yeah, I already shut every background program down except explorer and systray (sp?), I'm running WIN 98
Who Needs 8 is offline  
post #5 of 9 (permalink) Old 05-05-2003, 11:13 AM
 
Join Date: Oct 2001
Posts: 1,245
Well if you restart in DOS you can run defrag.exe.
Oxidizer187 is offline  
post #6 of 9 (permalink) Old 05-05-2003, 12:19 PM Thread Starter
BELIEVE, IT'S TIME!!!!
 
Who Needs 8's Avatar
 
Join Date: Mar 2001
Location: A little here, a little there . . .
Posts: 14,997
I can't even run scandisk in DOS anymore. It says file not found. Then the only DEFRAG in in c:\>WINDOWS\ and then if I try to run that it says must be run in Windows.

Uggg . . . Damn you Bill Gates . . . . hey there's a knock at my door . . . .
Who Needs 8 is offline  
post #7 of 9 (permalink) Old 05-05-2003, 12:26 PM
 
Join Date: Oct 2001
Posts: 1,245
Quote:
Originally posted by Who Needs 8
I can't even run scandisk in DOS anymore. It says file not found. Then the only DEFRAG in in c:\>WINDOWS\ and then if I try to run that it says must be run in Windows.

Uggg . . . Damn you Bill Gates . . . . hey there's a knock at my door . . . .
Can you run scandisk.exe?
Oxidizer187 is offline  
post #8 of 9 (permalink) Old 05-05-2003, 01:03 PM Thread Starter
BELIEVE, IT'S TIME!!!!
 
Who Needs 8's Avatar
 
Join Date: Mar 2001
Location: A little here, a little there . . .
Posts: 14,997
I changed the msconfig to restart windows with bare basic utilities, then I ran defrag in windows with "Runefrag.exe /All" so that it won't stop when the disk information changes. I read how to do this on a webpage. It's working smooth now.
Who Needs 8 is offline  
post #9 of 9 (permalink) Old 05-06-2003, 01:53 PM
You lookin' at mah EYE?!
 
DarkWolf's Avatar
 
Join Date: May 2000
Location: Portland, OR
Posts: 8,316
It's a good thing you didn't go through with the DOS defrag. I did that when Win95 was around, and it completely jacked the long file names, changing them back the the 8.3 format, and completely hosing the installation.

Another way to get the Windows one working, is to boot into Safe Mode and do a defrag from there.

DarkWolf
Graphic Design / Photography / Web Design
DarkWolf is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome