Home Networking Issues - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 20 (permalink) Old 04-21-2003, 11:07 AM Thread Starter
 
Join Date: Oct 2000
Posts: 7,291
Home Networking Issues

Ok, here's the problem.

My computer is the host, and right now there is only one client. The client computer is connected to me, and can see me. I can see the client computer, and rummage around through the shared drives. The client computer does use the internet connection through this computer, but it can't get on the internet currently.

I've tried making a new network connection, and that didn't help. I've made sure that the client computer is able to use the connection coming into the host computer as well.

Anyone have any suggestions???

- Jeremy
Poisond281 is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old 04-21-2003, 11:19 AM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
how are you doing this, proxy server, gateway, router software on the server?
AbecX is offline  
post #3 of 20 (permalink) Old 04-21-2003, 11:24 AM Thread Starter
 
Join Date: Oct 2000
Posts: 7,291
Just using a router. I'm sure some kinda setting got FUBAR'd, and I can't find it at the moment. The router is seeing both connections (host and client), so I'm doubting it's a hardware issue as well.
Poisond281 is offline  
 
post #4 of 20 (permalink) Old 04-21-2003, 11:26 AM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
Is it a software based router or is a hardware router like a linksys?
AbecX is offline  
post #5 of 20 (permalink) Old 04-21-2003, 11:33 AM Thread Starter
 
Join Date: Oct 2000
Posts: 7,291
Linksys router.
Poisond281 is offline  
post #6 of 20 (permalink) Old 04-21-2003, 11:36 AM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
Why dont you just sit the windows computer to DHCP instead of plugging in ip address? If you already have, does it DHCP an address in the 192.168.1.x domain? Try typing this in cmd prompt:

ping abecx.net

If you get no replies back try

ping 12.239.60.105

if you get a reply back, then your dns servers are not right.

edit: doh, my site doesnt reply to pings, try

ping monster.com
ping 64.85.13.200


Last edited by AbecX; 04-21-2003 at 11:38 AM.
AbecX is offline  
post #7 of 20 (permalink) Old 04-21-2003, 11:56 AM Thread Starter
 
Join Date: Oct 2000
Posts: 7,291
It does DHCP an IP like that to the client. Everything else checked out fine though. I can ping out fine, and when I pinged 12.239.60.105, it timed out.
Poisond281 is offline  
post #8 of 20 (permalink) Old 04-21-2003, 11:59 AM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
So it can ping domains and ip's fine, but its having problems using the internet?
AbecX is offline  
post #9 of 20 (permalink) Old 04-21-2003, 12:10 PM Thread Starter
 
Join Date: Oct 2000
Posts: 7,291
LOL. I shoulda been more clear on that one. The host can fine, but not the client.
Poisond281 is offline  
post #10 of 20 (permalink) Old 04-21-2003, 12:27 PM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
Both computers are clients if they are using a linksys router. I'm confused...
AbecX is offline  
post #11 of 20 (permalink) Old 04-21-2003, 12:30 PM Thread Starter
 
Join Date: Oct 2000
Posts: 7,291
The computer I'm on works fine (obviously), the other doesn't. ICS is on. There shouldn't be a problem, but there is. I'm confused too.
Poisond281 is offline  
post #12 of 20 (permalink) Old 04-21-2003, 12:50 PM
date +%H:%M | grep 4:20
 
Join Date: Jan 2003
Location: forty four & two
Posts: 278
host can refer to the pc providing services. typically this is also referrenced as a client/server setup. the client accesses the host's resources, i.e. internet connectivity in this guy's case or it could be mail, games, etc. or if you have a bastion host, this pc can provide access as a jump box into a remote network that's for all intents and purposes behind a firewall. each pc can be physically connected to a router. just depends what the pc is doing. server functions or client functions. but a host can also be a client as well. weeeee!!!!
evilmonk is offline  
post #13 of 20 (permalink) Old 04-21-2003, 12:52 PM Thread Starter
 
Join Date: Oct 2000
Posts: 7,291
Thanks for explaining it in detail.

Got any insight on the problem?
Poisond281 is offline  
post #14 of 20 (permalink) Old 04-21-2003, 01:13 PM
XL
 
Join Date: Sep 2001
Posts: 1,575
Try just doing a "release/renew" on the computer that isn't working.

Go into MS-DOS mode (type: "cmd" in the run menu if you are using XP).

Type ipconfig /release *

then

Type ipconfig /renew *

Try the internet connection now. Sometimes when a computer can't get to the internet I try that.
XL is offline  
post #15 of 20 (permalink) Old 04-21-2003, 01:16 PM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
wtf are you using ICS for? Turn that shit off.

Your router is the point of contact to get to the internet, both computers are clients.
AbecX is offline  
post #16 of 20 (permalink) Old 04-21-2003, 01:31 PM
date +%H:%M | grep 4:20
 
Join Date: Jan 2003
Location: forty four & two
Posts: 278
is your internet connection powered by pppoe? if so it could be an incompatible mtu setting. assuming you're using windows xp or 2000, windows uses a value of 1500 whereas pppoe uses 1492 or 1454. your client try:

ping -f -l 1500 (your default gateway)

if you get a fragmentation error try:

PING -f -l 1492 (your def....)

then the value 1454. if you don't get an error at 1500 then this will be a diferrent issue. if you do get an error there will be other things you'll need to do with the registry. lemme know and i'll dig it up.
evilmonk is offline  
post #17 of 20 (permalink) Old 04-21-2003, 03:49 PM Thread Starter
 
Join Date: Oct 2000
Posts: 7,291
Quote:
Originally posted by evilmonk
is your internet connection powered by pppoe? if so it could be an incompatible mtu setting. assuming you're using windows xp or 2000, windows uses a value of 1500 whereas pppoe uses 1492 or 1454. your client try:

ping -f -l 1500 (your default gateway)

if you get a fragmentation error try:

PING -f -l 1492 (your def....)

then the value 1454. if you don't get an error at 1500 then this will be a diferrent issue. if you do get an error there will be other things you'll need to do with the registry. lemme know and i'll dig it up.
I did all that, and the second one returned no error (using the 1492 value)
Poisond281 is offline  
post #18 of 20 (permalink) Old 04-21-2003, 04:26 PM
date +%H:%M | grep 4:20
 
Join Date: Jan 2003
Location: forty four & two
Posts: 278
sorry about the delay. at work. if you got an error with 1500 but not 1492 try:

1. run regedit. BACK UP YOUR REGISTRY!! i have no idea what os you're using or if this will specifically work in your case. this is for winXP/2000.

2. go to HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Tcpip\ Parameters\ Interfaces

3. there could be several subkeys under the interfaces key. view the contents of each key and find the one that corresponds to your network adapter. it will be the one with more values than the other two and will have an IP address value set to something like 192.x.x.x. look under the data field at teh far right.

4. once you've found the correct subkey, create a new DWORD value in it (from the file menu do: edit --> new --> DWORD value), and name the value MTU.

5. double-click the new value abd choose the decimal option then type the MTU value which would be 1492

6. click ok when you're done and then restart.

if that doesn't work lemme know and i'll have to actually look around for stuff.
evilmonk is offline  
post #19 of 20 (permalink) Old 04-23-2003, 10:20 AM
Bite Me!!!
 
I Stang U's Avatar
 
Join Date: Jul 2000
Location: A new Beast in Town!!
Posts: 2,457
man this should be really easy...

First turn off ICS


Plug your moden into the router
plug both your pc's to the router
set your machines to pull an ip addy from dhcp
configure router for NAT
If your router will not broadcast the dns ip addys you will need to set that info on each machine.

then you should be on the internet... ?????
I Stang U is offline  
post #20 of 20 (permalink) Old 04-24-2003, 12:49 AM
You lookin' at mah EYE?!
 
DarkWolf's Avatar
 
Join Date: May 2000
Location: Portland, OR
Posts: 8,316
Quote:
Originally posted by I Stang U
man this should be really easy...

First turn off ICS


Plug your moden into the router
plug both your pc's to the router
set your machines to pull an ip addy from dhcp
configure router for NAT
If your router will not broadcast the dns ip addys you will need to set that info on each machine.

then you should be on the internet... ?????
That's kinda what I was thinking. That's my setup.

DarkWolf
Graphic Design / Photography / Web Design
DarkWolf is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome