Any BIND gurus? - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 02-27-2003, 09:11 AM Thread Starter
Mmmm.. Nekkid Twins
 
Llama_Boy's Avatar
 
Join Date: Aug 2001
Location: Lake Dallas
Posts: 2,306
Any BIND gurus?

I am running F-secure Namesurfer which dynamical updates my DNSs. When Namesurfer updates a zone, it sends a notification to both of my NSs, and then, they update their zones, but at the same time, each of the NSs sends a notification to every authoritative NS defined in their zones. So they will also send a notification to each other. Is it possible to stop them from sending the notification to one another but still send it to all the other authoritative NS defined in their zones?


Gurus?
Llama_Boy is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 02-27-2003, 09:18 AM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
setup your /etc/named.conf

zone "abecx.net" {
type master;
file "abecx.net.zone";
allow-transfer { 192.168.0.1, 192.168.0.2; };

You might want to use the other ones as slaves.
AbecX is offline  
post #3 of 7 (permalink) Old 02-27-2003, 09:20 AM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
You'll have to copy and paste the link.

'http://abecx.net/O'reilly%20Books/Network%20Bookshelf/dnsbind/ch08_02.htm'


This might help too.
AbecX is offline  
 
post #4 of 7 (permalink) Old 02-27-2003, 09:36 AM Thread Starter
Mmmm.. Nekkid Twins
 
Llama_Boy's Avatar
 
Join Date: Aug 2001
Location: Lake Dallas
Posts: 2,306
Are you using the BIND 8 notify feature? Basically I'm using Namesurfer to update (2)primary NSs which in-turn Notify their slaves, but the (2) primary's are updating each other also... this is what I would like to stop without effecting any other functionality.

Can you explain what needs to be removed/added to the named.conf to remove the NSs from each others "notify process"?
Llama_Boy is offline  
post #5 of 7 (permalink) Old 02-27-2003, 09:52 AM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
I am using BIND 9, but the configutation files are the same I believe.

Show me what your /etc/named.conf file looks like, just the sections in question.
AbecX is offline  
post #6 of 7 (permalink) Old 02-27-2003, 10:07 AM Thread Starter
Mmmm.. Nekkid Twins
 
Llama_Boy's Avatar
 
Join Date: Aug 2001
Location: Lake Dallas
Posts: 2,306
I'll try to get them.. the servers aren't easily accessible.
Llama_Boy is offline  
post #7 of 7 (permalink) Old 02-27-2003, 10:39 AM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
alright, well you can type man named.conf, read up on the sections regarding notify and/or the Access section ( mainly allow-transfer ). Its not hard to setup correctly, but understanding the boring man file is.

If you get ahold of the named.conf sections, post up a jpg of the way its supposed to handle updates ( like a chart of each ns ), and I'll set the named.conf up correctly.

<-- bored.

Last edited by AbecX; 02-27-2003 at 10:42 AM.
AbecX is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome