xbox 360 blank screen - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 01-12-2009, 10:45 AM Thread Starter
Army Strong
 
turbodriven's Avatar
 
Join Date: Jun 2006
Location: Colorado Springs, Co
Posts: 1,284
xbox 360 blank screen

Hey guys, I need a little help. My grandparents bought my cousin a xbox 360 for his birthday. It was used. It worked for about an hour and now when you turn it on you can hear sound but no picture. They have already bought a new cable and that didn't fix it. Any ideas? Oh, and it doesn't have the red ring of death, the lights are still green. Thanks for the help in advance.

Quote:
Originally Posted by AL P View Post
There are two kinds of people in this world son, those that jerk off and those that lie about it.
Quote:
Originally Posted by Geor! View Post
Weird, cuz I'd rather be out on the streets sucking dick for crack than working!
http://www.phoenixtears.ca/ Cancer cure.
turbodriven is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 01-12-2009, 11:25 AM
Time Served
 
Join Date: Sep 2002
Location: In a house
Posts: 255
Mine did the same thing. The video card went out. I had to spend 100 bucks and send it back to microsoft, when you do that they give you a year warranty with it.

Larius is offline  
post #3 of 9 (permalink) Old 01-12-2009, 11:27 AM
Time Served
 
Join Date: Aug 2007
Posts: 956
360's always have issues!! That's why I never bought one..
Web Guy is offline  
 
post #4 of 9 (permalink) Old 01-12-2009, 11:32 AM
Time Served
 
Join Date: Jul 2004
Location: Plano
Posts: 711
try a different type of cable (composite, component, or hdmi)

also, if you are using the composite/component cable there is a little switch on the housing part that plugs into the 360 that switches it between HDTV and SD (HDTV is for component hookup, SD is for the composite). make sure that switch is on the correct setting or you won't get a picture.

'01 Bullitt #0054
bullitt54 is offline  
post #5 of 9 (permalink) Old 01-12-2009, 11:35 AM
Lifer
 
Lason's Avatar
 
Join Date: Nov 2001
Location: arlington
Posts: 11,144
Mine did the same thing. Would work for a couple minutes then the screen would go green/blue then no picture at all. MS said it was the graphics gpu that was bad but it was just overheating. Took it apart, used some new Silver Arctic thermal compound on the GPU and CPU and replaced the X clamps for the heatsinks with some nuts and bolts and now it works fine. Google X-clamp mod for the 360's if you wanna fix it for $10 and dont order those kits, you can get the same thing at home depot and frys for less.
Lason is offline  
post #6 of 9 (permalink) Old 01-12-2009, 11:52 AM
Lifer
 
Join Date: Jul 2000
Location: Rowlett, TX
Posts: 1,463
May sound stupid, but make sure your TV is set to the correct input.
Way Cool Jr is offline  
post #7 of 9 (permalink) Old 01-12-2009, 11:57 AM
Time Served
 
Join Date: Aug 2007
Posts: 956
Quote:
Originally Posted by Way Cool Jr View Post
May sound stupid, but make sure your TV is set to the correct input.
I was going to say the same thing after some more time to think about the issue. When I first hooked up my PS3 I bought used it would only show a black screen because my TV was not set up to the output from the PS3.
Web Guy is offline  
post #8 of 9 (permalink) Old 01-12-2009, 03:47 PM Thread Starter
Army Strong
 
turbodriven's Avatar
 
Join Date: Jun 2006
Location: Colorado Springs, Co
Posts: 1,284
The tv is setup correctly cause it was working great and then just bleeped off. I will check out the x clamp mod. I will prolly just call MS.

Quote:
Originally Posted by AL P View Post
There are two kinds of people in this world son, those that jerk off and those that lie about it.
Quote:
Originally Posted by Geor! View Post
Weird, cuz I'd rather be out on the streets sucking dick for crack than working!
http://www.phoenixtears.ca/ Cancer cure.
turbodriven is offline  
post #9 of 9 (permalink) Old 01-12-2009, 11:04 PM
Lifer
 
johnny1999's Avatar
 
Join Date: Mar 2005
Location: Van Alstyne
Posts: 1,168
Contact MS and see if it is still under warranty. If so that is your best option, if not I can do the x clamp fix for you. You can come by my office and I will do it with you if you want. It may not fix it, but it is worth a try if you cant get MS to help.

Johnny
johnny1999 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome