Firefox running like s#$@ - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-21-2007, 09:47 PM Thread Starter
Lifer
 
Trip McNeely's Avatar
 
Join Date: Mar 2004
Posts: 29,396
Thumbs down Firefox running like s#[email protected]

Lately my Firefox browser has been running like shit. Its REALLY slow, sometimes wont load images, and takes 10 minutes to load Youtube videos. I have to go to my IE now and it finally loads on that better. What gives? I did the speed up trick a few months ago and it worked great, but recently its been a PITA. Any suggestions? Thanks.

CANADIANS = DOUCHERS

Trip McNeely is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-21-2007, 10:02 PM
AEA
 
Join Date: Apr 2003
Posts: 111
Same here....but I think mine is the Hughesnet satellite as opposed to the Firefox Browser.
AEA is offline  
post #3 of 6 (permalink) Old 06-21-2007, 10:15 PM Thread Starter
Lifer
 
Trip McNeely's Avatar
 
Join Date: Mar 2004
Posts: 29,396
I dont know what it is. Its mostly on graphic intensive sites, or video. My IE runs fine though, so thats why I think its Firefox. I just hate to use IE, but in this case its running better.

CANADIANS = DOUCHERS

Trip McNeely is offline  
 
post #4 of 6 (permalink) Old 06-21-2007, 10:20 PM
duh...duh....duh
 
ceyko's Avatar
 
Join Date: Aug 2004
Location: ES BEER
Posts: 9,543
Uninstall reinstall?

My '03 Sold.
ceyko is offline  
post #5 of 6 (permalink) Old 06-22-2007, 03:00 AM
You lookin' at mah EYE?!
 
DarkWolf's Avatar
 
Join Date: May 2000
Location: Portland, OR
Posts: 8,316
Quote:
Originally Posted by 1BAD06
Lately my Firefox browser has been running like shit. Its REALLY slow, sometimes wont load images, and takes 10 minutes to load Youtube videos. I have to go to my IE now and it finally loads on that better. What gives? I did the speed up trick a few months ago and it worked great, but recently its been a PITA. Any suggestions? Thanks.
Other than the obvious clear cache, cookies, and history. If that doesn't work, uninstall/reinstall Fx.

Beyond that, more specific info is going to be needed. What new programs have you put on the system in the last few months? What security/program updates have you made in the last few months? Are you using the latest version of Firefox? What extensions do you have installed? What background monitors (anti-virus, firewalls, spyware, etc) do you have running?

Just saying it's "slow" doesn't help us in trying to figure out what might be causing it to be "slow"

DarkWolf
Graphic Design / Photography / Web Design
DarkWolf is offline  
post #6 of 6 (permalink) Old 06-22-2007, 07:50 AM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
Go back to IE then, no one really gives a shit. Firefox = Greater. You probably have a shit load of spyware and other bullshit on your computer.

AbecX is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome