linux video player - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 01-28-2005, 03:01 AM Thread Starter
Fear the lawn gnome
 
sleeperLS's Avatar
 
Join Date: Jul 2001
Location: if you want it blown up let me have it.
Posts: 4,535
linux video player

what is the best one. im still a newbie but since my windows hard drive took a dump and i have no windows disk. so now im forced to learn it. and it sucks not being able to watch vids. i noticed m player but i cant get the damn thing to install. i dled it. but like i said i could be doing something wrong. im logged in as root right now. but if anyone has any good ones i can search for post it up.

What you might call solitude is something i look forward to.
sleeperLS is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 01-28-2005, 06:47 AM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
mplayer

AbecX is offline  
post #3 of 12 (permalink) Old 01-28-2005, 09:50 AM
 
Join Date: Nov 2002
Posts: 5,831
Thumbs up

Quote:
Originally Posted by AbecX
mplayer
agree
trey85stang is offline  
 
post #4 of 12 (permalink) Old 01-28-2005, 12:08 PM Thread Starter
Fear the lawn gnome
 
sleeperLS's Avatar
 
Join Date: Jul 2001
Location: if you want it blown up let me have it.
Posts: 4,535
thats what i figured. now i just gotta get it to work

What you might call solitude is something i look forward to.
sleeperLS is offline  
post #5 of 12 (permalink) Old 01-28-2005, 03:35 PM
You lookin' at mah EYE?!
 
DarkWolf's Avatar
 
Join Date: May 2000
Location: Portland, OR
Posts: 8,316
Hmmm:
Quote:
[[email protected] downloads]# rpm -Uvh mplayer-gui-1.0pre6-1.i386.rpm
warning: mplayer-gui-1.0pre6-1.i386.rpm: V3 DSA signature: NOKEY, key ID 75aa026a
error: Failed dependencies:
mplayer-skin-default is needed by mplayer-gui-1.0pre6-1.i386
[[email protected] downloads]# rpm -Uvh mplayer-skin-default-1.4-1.noarch.rpm
warning: mplayer-skin-default-1.4-1.noarch.rpm: V3 DSA signature: NOKEY, key ID75aa026a
error: Failed dependencies:
mplayer-gui is needed by mplayer-skin-default-1.4-1.noarch
wtf?!

So I installed mplayer, but try to install the gui and it says it needs the skin default, so I go to install the skin default, and it says it needs the gui. Retarded, much?

DarkWolf
Graphic Design / Photography / Web Design
DarkWolf is offline  
post #6 of 12 (permalink) Old 01-28-2005, 03:36 PM
Lifer
 
HiTechRedneck's Avatar
 
Join Date: Jul 2003
Posts: 1,063
./configure

make

su -

make install
HiTechRedneck is offline  
post #7 of 12 (permalink) Old 01-28-2005, 04:17 PM
You lookin' at mah EYE?!
 
DarkWolf's Avatar
 
Join Date: May 2000
Location: Portland, OR
Posts: 8,316
Used apt-get instead and it's all good now.

DarkWolf
Graphic Design / Photography / Web Design
DarkWolf is offline  
post #8 of 12 (permalink) Old 01-28-2005, 04:19 PM
You lookin' at mah EYE?!
 
DarkWolf's Avatar
 
Join Date: May 2000
Location: Portland, OR
Posts: 8,316
Quote:
Originally Posted by HiTechRedneck
./configure

make

su -

make install
Haven't had a whole lot of luck compiling. Some things work fine, others either fail during ./configure, or go through that and seem to be fine, but then fail instantly with make.

I was trying to compile gtk+2.6, so I got all the latest glib, pango, atk sources. glib compiled and installed like a charm. atk failed make. pango failed ./configure because no freetype was installed... so I downloaded, compiled and installed both freetype and freetype2 ... pango still fails ./configure saying no freetype was installed.

I don't even remember what the problem with atk was. It went through ./configure like it was going to do ok, but during make it kept erroring.

I'd love for it to be that simple, every time :-/

DarkWolf
Graphic Design / Photography / Web Design
DarkWolf is offline  
post #9 of 12 (permalink) Old 01-29-2005, 12:21 PM
Time Served
 
Join Date: Jan 2002
Location: Bedford, TX
Posts: 761
Does mplayer support DD and DTS with digital connection? If not, do any of the Linux media players? I would like to try DVD playback on Linux.
Sami is offline  
post #10 of 12 (permalink) Old 01-29-2005, 03:05 PM
You lookin' at mah EYE?!
 
DarkWolf's Avatar
 
Join Date: May 2000
Location: Portland, OR
Posts: 8,316
Ogle does DVD playback. I assume with DD and DTS support, but I haven't looked into it to make sure.

Also, I was having some problem at the beginning where the dvd plays it's requisit "logo" screen for whichever studio released the dvd (in my case a Warner Bros. logo), and would then shut Ogle down. Got around it by hitting the "Next" button to force it to skip past the logo. Haven't tried many DVD's on it yet to see if this is a common thing or if it's just something fucked up with that one disc.

Also, having some problems compiling Beep Media Player, wanted to check it out and compare it to XMMS. During ./configure it's erroring out while searching for the Qt headers and libraries. apt-get everything I could for Qt, including qt-devel, and even compiled/installed the latest qt-x11-free-3.3.4. I've rebooted the computer since to make sure it wasn't something weird needing a reboot to take effect, but it's still not seeing that I have Qt installed, to continue compiling it :-/

Any ideas? It's also giving me this error when I try to compile one of the themes I downloaded, only difference is the theme is looking for Qt >= 3.2 and Beep is looking for Qt >= 3.0. Having 3.3.4 I would assume to be sufficient... if they'd see it.

DarkWolf
Graphic Design / Photography / Web Design
DarkWolf is offline  
post #11 of 12 (permalink) Old 01-29-2005, 08:13 PM
 
Join Date: Nov 2002
Posts: 5,831
Quote:
Originally Posted by DarkWolf
Ogle does DVD playback. I assume with DD and DTS support, but I haven't looked into it to make sure.

Also, I was having some problem at the beginning where the dvd plays it's requisit "logo" screen for whichever studio released the dvd (in my case a Warner Bros. logo), and would then shut Ogle down. Got around it by hitting the "Next" button to force it to skip past the logo. Haven't tried many DVD's on it yet to see if this is a common thing or if it's just something fucked up with that one disc.

Also, having some problems compiling Beep Media Player, wanted to check it out and compare it to XMMS. During ./configure it's erroring out while searching for the Qt headers and libraries. apt-get everything I could for Qt, including qt-devel, and even compiled/installed the latest qt-x11-free-3.3.4. I've rebooted the computer since to make sure it wasn't something weird needing a reboot to take effect, but it's still not seeing that I have Qt installed, to continue compiling it :-/

Any ideas? It's also giving me this error when I try to compile one of the themes I downloaded, only difference is the theme is looking for Qt >= 3.2 and Beep is looking for Qt >= 3.0. Having 3.3.4 I would assume to be sufficient... if they'd see it.
In my experience with Fedora, its much easier to try and find rpm's for any software you might want. There are some links out there about adding custom repsoitories.. I wish i had one of the links but it gave a long list of alternate repos that have most of the software you seem to be having problems compiling.

As for XMMS and Beep... the only difference is the user interface, XMMS is built of GTK1.2, Beep is build for GTK2. imo xmms is more feature rich then Beep.
trey85stang is offline  
post #12 of 12 (permalink) Old 01-30-2005, 12:15 AM
You lookin' at mah EYE?!
 
DarkWolf's Avatar
 
Join Date: May 2000
Location: Portland, OR
Posts: 8,316
Gotcha.

I'm using Madman media manager (not quite as good as Winamp's media library, but it works) to set up auto-playlists, however it's strict about using ID3v1 tags, rather than looking at either v1 or v2, and that kinda sucks since v2 let's you do custom genre's (like Movie Soundtrack, instead of just Soundtrack). Is there any media library type app that handles v2 tags? Also would be nice, if I have to stick with v1 tags, to be able to mass edit the tags (ie: grab a bunch of songs that were v2'd as Movie Soundtrack, and v1 them to Soundtrack).

Also, was reading a bit on wasabi.player, being the opensource Winamp, but all I've found for it is windows related, and can't seem to find the source to try and compile it.

DarkWolf
Graphic Design / Photography / Web Design
DarkWolf is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome