redhat ATI 9700Pro driver install??? - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 10-22-2003, 07:30 PM Thread Starter
 
Join Date: Nov 2002
Posts: 5,831
Angry redhat ATI 9700Pro driver install???

OK, how do you install the ATI driver for the 9700pro? I installed as the read me states... everything seems to run fine.. I ran through the fglrxconfig, restarted.. everything works fine... but when opening any game.. i get framerates of about 2 fpm (frames per minute)

anyideas of what I can do? Worst case.. is there anyway I can go back to the default redhat driver?

thanks
trey
trey85stang is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-22-2003, 09:23 PM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
In the Module section, make sure you have:
Load "glx"

You should also remove the following lines:
Load "dri"
Load "GLcore"
AbecX is offline  
post #3 of 8 (permalink) Old 10-23-2003, 10:56 AM Thread Starter
 
Join Date: Nov 2002
Posts: 5,831
sounds good.. but im unfamiliar with the "module section" what is the name of the file?
trey85stang is offline  
 
post #4 of 8 (permalink) Old 10-23-2003, 12:19 PM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
Quote:
Originally posted by trey85stang
sounds good.. but im unfamiliar with the "module section" what is the name of the file?
You'll see a section called module

/etc/X11/XF86Config ( might be XF86Config-4 depending on RH distro ).
AbecX is offline  
post #5 of 8 (permalink) Old 10-23-2003, 05:36 PM Thread Starter
 
Join Date: Nov 2002
Posts: 5,831
ok.. got it.. i removed

load "dri

but there was no glcore... and glx was already there... there is also a section called "DRI" should this be removed?
trey85stang is offline  
post #6 of 8 (permalink) Old 10-23-2003, 06:12 PM Thread Starter
 
Join Date: Nov 2002
Posts: 5,831
hmmm... i went ahead and reinstalled... but im getting the same thing here is the output from the rpm.. install and everything... looks good right?

[[email protected] trey]# rpm -Uvh --force fglrx*
Preparing... ########################################### [100%]
1:fglrx-glc22 ########################################### [100%]
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
probing for VMA API version...
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
patching 'drm_os_linux.h'...
doing script based build for kernel 2.4.x and similar
compiling 'agpgart_be.c'...
compiling 'agp3.c'...
compiling 'i7505-agp.c'...
compiling 'nvidia-agp.c'...
compiling 'firegl_public.c'...
linking of fglrx kernel module...
duplicating results into driver repository...
done.
==============================
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.20-8/kernel/drivers/char/drm/fglrx.o will tain
t the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnb
erg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modu
les
Module fglrx loaded, with warnings
done.
Installed: qt3 (gcc 3.2) based control panel application
===
ATI display drivers successfully installed
please run 'fglrxconfig' now
===
[[email protected] trey]# cd /lib/modules/fglrx/build_mod
[[email protected] build_mod]# ./make.sh
ATI module generator V 2.0
==========================
initializing...
probing for VMA API version...
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
patching 'drm_os_linux.h'...
doing script based build for kernel 2.4.x and similar
compiling 'agpgart_be.c'...
compiling 'agp3.c'...
compiling 'i7505-agp.c'...
compiling 'nvidia-agp.c'...
compiling 'firegl_public.c'...
linking of fglrx kernel module...
duplicating results into driver repository...
done.
==============================
You must change your working directory to /lib/modules/fglrx
and then call ./make_install.sh in order to install the built module.
==============================
[[email protected] build_mod]# cd /lib/modules/fglrx
[[email protected] fglrx]# ./make_install.sh
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.20-8/kernel/drivers/char/drm/fglrx.o will tain t the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnb erg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modu les
Module fglrx loaded, with warnings
done.
[[email protected] fglrx]#
trey85stang is offline  
post #7 of 8 (permalink) Old 10-24-2003, 04:54 PM
¯\(º_o)/¯
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
Please put that box on a external connection so I can fix it
AbecX is offline  
post #8 of 8 (permalink) Old 10-24-2003, 09:17 PM Thread Starter
 
Join Date: Nov 2002
Posts: 5,831
Quote:
Originally posted by AbecX
Please put that box on a external connection so I can fix it
damn.. i wish i could maybe this weekend i can try and get it on an external connection.. right now im going through a proxy.
trey85stang is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome