Amp & Sub Help! - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-03-2008, 04:33 PM Thread Starter
LUCIFER
 
bjtheman1's Avatar
 
Join Date: Jun 2007
Location: Aubrey
Posts: 5,462
Thumbs down Amp & Sub Help!

Was driving home from work today when all of a sudden my sub stopped, just had a chance to play with it and I can't figure out wtf is wrong. I'm pretty sure it's my amp b/c I have 2 different Kicker CompVr 10's..one Dual 4ohm, and one Dual 2ohm. I only use one of them also!
I tried wiring them from bridged mode to regular one or two channel, but a signal would never pass through? The amp is on, power lights up..I just don't have a clue what it is?

Any input? It's a Kicker 350.2KX

2004 GT Conv't

MODS:
FLOWS, 3.73'S, BASSANI O/R X-PIPE, ACCUFAB 75MM TB, PLENUM, AND VORTECH V-3 SUPERCHARGED


bjtheman1 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-03-2008, 05:10 PM Thread Starter
LUCIFER
 
bjtheman1's Avatar
 
Join Date: Jun 2007
Location: Aubrey
Posts: 5,462
Alright, after playing with it some more....If I press down on the middle of the sub it starts working, when I remove that pressure it stops?
WTF, this doesn't add up. I even have the dual 2ohm 10 that I was running for the longest and it's doing the same thing as the 4ohm I just got about 2 weeks ago

2004 GT Conv't

MODS:
FLOWS, 3.73'S, BASSANI O/R X-PIPE, ACCUFAB 75MM TB, PLENUM, AND VORTECH V-3 SUPERCHARGED


bjtheman1 is offline  
post #3 of 3 (permalink) Old 09-03-2008, 05:33 PM Thread Starter
LUCIFER
 
bjtheman1's Avatar
 
Join Date: Jun 2007
Location: Aubrey
Posts: 5,462
Fixed it, wow now this is a bit ridiculous...on each speaker one of the terminals had a loose wire attached to it. I had to use a tie to keep it attached to the lead so it would get the signal.
I've always loved kicker and never had any probs till I got these 10's...I miss my old 12!

2004 GT Conv't

MODS:
FLOWS, 3.73'S, BASSANI O/R X-PIPE, ACCUFAB 75MM TB, PLENUM, AND VORTECH V-3 SUPERCHARGED


bjtheman1 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome