Bringing Sexy Back - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 04-01-2008, 07:14 PM Thread Starter
Time Served
 
Join Date: Mar 2005
Posts: 215
Bringing Sexy Back

More pics of other OLD SKOOL STUFF.... scroll down

Thanx to larry for these nice badass old skool amps


Old School Rockford Fosgate Power 1000 Mosfet


Specs @ 12.5v

4 x 150W @ 4 ohms
4 x 250W @ 2 ohms
2 x 500W @ 4 ohms bridged
Fuse: External 100A














Last edited by slam; 04-02-2008 at 03:12 PM.
slam is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 04-01-2008, 07:15 PM Thread Starter
Time Served
 
Join Date: Mar 2005
Posts: 215
2 Old School Lanzar Optidrive 2500

Specs @ 12.4v

2 x 250W @ 4 ohms (0.01% THD)
2 x 500W @ 2 ohms
1 x 1000W @ 4 ohms bridged
Fuse: External 120A





















slam is offline  
post #3 of 16 (permalink) Old 04-01-2008, 09:54 PM
 
Join Date: Jan 2001
Posts: 801
God I love those old battery goblin alternator killin amps.

Wish I had some of mine back.
jbullerjr is offline  
post #4 of 16 (permalink) Old 04-01-2008, 09:56 PM
Mexican Crew
 
paul_376's Avatar
 
Join Date: Jul 2007
Posts: 4,612
i had some of those in my cutlass supreme back in the day...

Quote:
Check your self bro , you're not that cool.

paul_376 is offline  
post #5 of 16 (permalink) Old 04-02-2008, 07:38 AM
893
Lifer
 
Join Date: Mar 2001
Posts: 16,774
I am still running my circa 1997 Punch 200 in my Z Love that thing. Pushes my w6 with ease. Last year I gave up my same vintage phoenix gold mid/high amp when I sold my mustang. I should have kept it. That thing was a monster. Tear
893 is offline  
post #6 of 16 (permalink) Old 04-02-2008, 08:05 AM
yes, jluv
 
Join Date: May 2001
Posts: 17,073
I had an old black and red Punch 40 in like '95 or '96. That little thing pushed two Punch 12s sealed with ease. Then I went with a bunch of PPI art series amps. Yummy.
jluv is offline  
post #7 of 16 (permalink) Old 04-02-2008, 08:25 AM
Boneless
 
Magnimike1's Avatar
 
Join Date: Aug 2004
Location: Under a bowtie
Posts: 3,226
Quote:
Originally Posted by jluv
I had an old black and red Punch 40 in like '95 or '96. That little thing pushed two Punch 12s sealed with ease. Then I went with a bunch of PPI art series amps. Yummy.
The punch 45 timeless

I had a 75 and a few of the optidrive amps as well. Very quality products
Magnimike1 is offline  
post #8 of 16 (permalink) Old 04-02-2008, 08:27 AM
EW
Procrastination Racing
 
EW's Avatar
 
Join Date: Dec 2000
Location: Bedford, TX
Posts: 9,226
Yay for good old day syndrome.
EW is offline  
post #9 of 16 (permalink) Old 04-02-2008, 11:24 AM
893
Lifer
 
Join Date: Mar 2001
Posts: 16,774
Quote:
Originally Posted by Magnimike1
The punch 45 timeless

I had a 75 and a few of the optidrive amps as well. Very quality products


I had a punch 45 and a 75 as well. Good times.
893 is offline  
post #10 of 16 (permalink) Old 04-02-2008, 12:06 PM
 
Join Date: Jan 2001
Posts: 801
My first "real" system

In 1989 in my 88 Mustang GT vert

Aiwa head with the fold down door and a million buttons
Rockford Fosgate separates in the front
RF coaxs in the rear
Powered by a Punch 150
Two RF 10's in a sealed box
Powered by a Punch 75
jbullerjr is offline  
post #11 of 16 (permalink) Old 04-02-2008, 12:44 PM
duh...duh....duh
 
ceyko's Avatar
 
Join Date: Aug 2004
Location: ES BEER
Posts: 9,543
yall were high class rich kids or something. My first amp was a 300W craig amp pushing some kicker SS10s and a tape deck. Stock everything else.

My '03 Sold.
ceyko is offline  
post #12 of 16 (permalink) Old 04-02-2008, 12:52 PM
Got Lateral G's??
 
Join Date: Jan 2002
Location: Your mirror about to pass your ass!
Posts: 9,822
Talk about Nostalgia!!

I was a BIG PPI (2125 I think?) guy back in the day. Had 2 Kicker 15's in the trunk of my Lebaron GTS, then it was 4 12's, then two 12's, then 1 15 and 2 8's... Mids/highs was an MB Quart component set in the front and rear with a Kenwood deck... Later used all the same parts in other vehicles but had a 12w6 I finally killed about 4 years ago. then a couple punch 10's and killed those last year. I would love to put some 10's in my truck but space and money are limited....not ballin' like I was in HS anymore!!! LOL!!!



Looking for sponsorships for 2010 on the car above... PM for details and schedule.

I'm a mod motor GOD! LOL!
aggie97 is offline  
post #13 of 16 (permalink) Old 04-02-2008, 01:26 PM
 
Join Date: Jan 2001
Posts: 801
Quote:
Originally Posted by ceyko
yall were high class rich kids or something. My first amp was a 300W craig amp pushing some kicker SS10s and a tape deck. Stock everything else.
Not a rich kid, just old LOL
<-------working since 83
jbullerjr is offline  
post #14 of 16 (permalink) Old 04-02-2008, 01:30 PM
Rolling with the homies
 
evil jose's Avatar
 
Join Date: Apr 2000
Location: Oak Cliff... that's my hood...
Posts: 43,271
I always lusted for a Power 1000 "back in the day". First amp was a Pyramid PB600 (don't ask me how I remember that model number). After that amp got fried I saved up and bought a used setup of 2 Punch 75 75's powering 2 Petra 15's and a Punch 45 powering some Cerwin Vega mids and tweets. Very nice system running off of a Pioneer cassette deck.

Only thing I hated was how power hungry amps were back then. I went through a couple of alternators and always had issues with lights dimming with a heavy bass riff. Don't have those issues anymore with my JL 500/5

Nice find... brings back alot of memories.




2008 Lincoln MKZ
1995 Mustang GT Convertible
2002 F-150 SuperCrew


1995 Ford Taurus SHO
2003 Yamaha R6

evil jose is offline  
post #15 of 16 (permalink) Old 04-02-2008, 02:07 PM
yes, jluv
 
Join Date: May 2001
Posts: 17,073
Quote:
Originally Posted by evil jose
Only thing I hated was how power hungry amps were back then. I went through a couple of alternators and always had issues with lights dimming with a heavy bass riff. Don't have those issues anymore with my JL 500/5
Don't think that Slash amps aren't power hungry. Newer Fords just have decent alternators and electrical systems from the factory. That, and you aren't pushing a ton of power anyway. Step it up homie! If you're not dimming yet, there's plenty of room for growth!
jluv is offline  
post #16 of 16 (permalink) Old 04-02-2008, 03:11 PM Thread Starter
Time Served
 
Join Date: Mar 2005
Posts: 215
Got some more in today. These will be fosale soon.... the first gen Digital Reference

Orion HCCA225

Output Power at 12.5V:
2 x 25W @ 4 ohms
2 x 50W @ 2 ohms
2 x 100W @ 1 ohm
2 x 200W @ ohm
1 x 100W @ 4 ohms bridged
1 x 200W @ 2 ohms bridged
1 x 400W @ 1 ohm bridged
THD: 0.03%
S/N Ratio: 110dB
Fuse: External 35A
Freq. Response: 6Hz ∼ 20kHz (0.5dB)
Dimensions: 11" x 8.5" x 2.25" (28cm x 21.6cm x 5.7cm)
















Old Sckool Hifonics Thor VI

Power ratings at 11.5 to 16V:
2 x 125w @ 4 ohms (0.02% THD)
2 x 200w @ 2 ohms (0.1% THD)
1 x 400w @ 4 ohms bridged
Fuse: 35A (4 ohms) or 50A (2 ohms)









slam is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome