Stereo Stuff Accomplished - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-11-2002, 08:19 AM Thread Starter
\(_o)/
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
Stereo Stuff Accomplished

Well I got all my stuff installed and figured out. I had all 4 front speakers already, but the all the wires were all freaked up, so I re-ran them and I bought some 6x9 ( to big but i'll get them to fit ) for the back that are 3 way coaxil speakers. I also bought a mp3 player head unit for $129 by koss. Its kind of shitty and people tell me its just like the aiwa one. It puts out 160 watts and his a lot of distortion in it. Well, when I plugged it all up, I got my sound, and it wasnt what I wanted. The mids and lows were just not there for me. Luckily my friends sold me a 300watt x2 BOSS amp and I am using it to power the back speakers w/ it set on full range of sound. It sounds REALLY good, but the trunk has a little bit of rattle probably because they arent bolted down yet. Now its on to dynamat and new carpet and seats. I also put the new dash in btw, and it looks and is so much strudier then the painted black one that was broken when I got the car. I also plugged up my clarion ungo crazy alarm, and am missing the door lock and trunk function but I am doing some research into that as far as voltage and stuff. I still need to do the heater core and ac core which will be done when I pull the dash back out and put all new carpet and dynamat in as well as fill in the holes in the floorboard ( if any as far as water leakage etc. )

AbecX is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-11-2002, 09:05 AM
Rolling with the homies
 
evil jose's Avatar
 
Join Date: Apr 2000
Location: Oak Cliff... that's my hood...
Posts: 43,271
Congratulations, I'm assuming this is your first stereo install? Sounds like you may need some Dynamat or something similar to possible quell the rattles.




2008 Lincoln MKZ
1995 Mustang GT Convertible
2002 F-150 SuperCrew


1995 Ford Taurus SHO
2003 Yamaha R6

evil jose is offline  
post #3 of 4 (permalink) Old 04-11-2002, 09:36 AM
.
 
Join Date: Jun 2001
Posts: 7,214
Thumbs up

cool
SLP007 is offline  
 
post #4 of 4 (permalink) Old 04-11-2002, 09:41 AM Thread Starter
\(_o)/
 
AbecX's Avatar
 
Join Date: Nov 2001
Location: Las Colinas
Posts: 25,373
Quote:
Originally posted by evil jose
Congratulations, I'm assuming this is your first stereo install? Sounds like you may need some Dynamat or something similar to possible quell the rattles.
Actually I have installed a couple of stereo's before, this is my 3rd one. I have never used an amp before and it took me a while to figure out I could plug up the remote connection to the power antenna on the stereo

AbecX is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome