box for a JL sub? - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-21-2005, 05:01 PM Thread Starter
Lifer
 
kpc01's Avatar
 
Join Date: Dec 2002
Location: Oak Point TX
Posts: 1,433
box for a JL sub?

Anyone that can help me with which box is best for a JL sub, I have a JL 10w2 and needing to get a box...didn't know if I should go with bandpass...ported...not ported, or whatever. Any help is appreciated. Just wanting to put on ten in the trunk of the GT to get a little bass.

-04 CTS-V
-10 Jeep Commander
kpc01 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-21-2005, 08:04 PM
You break it, I fix it...
 
stang-man-man's Avatar
 
Join Date: Jul 2004
Location: Wrenchin' for Cash!!
Posts: 1,792
Just put nice little sealed box back there....The sub should come with a book that has the airspace requirements...Build box to suit.

To Taco Bell, or to Taco Bueno, that is the question...
stang-man-man is offline  
post #3 of 5 (permalink) Old 12-22-2005, 07:17 AM
EW
Procrastination Racing
 
EW's Avatar
 
Join Date: Dec 2000
Location: Bedford, TX
Posts: 9,226
A 10W2 is a VERY OLD WOOFER. Like 15 years old. Are you sure you have the right model number? If it really is a 10W2, JL does not recommend a sealed enclosure at all. They recommend a 2.5cu ft ported enclosure with a 3" round port 6.3" long.
Here is a link. Click on the "10W2" for all the build data. http://mobile.jlaudio.com/products_s...php?page_id=15
EW is offline  
 
post #4 of 5 (permalink) Old 12-22-2005, 03:00 PM Thread Starter
Lifer
 
kpc01's Avatar
 
Join Date: Dec 2002
Location: Oak Point TX
Posts: 1,433
cool, thanks...on which one, no I"m not positive. Its my brothers, and I told him I would build it and hook it all up during xmas when I saw him. I will check it out when I get home for christmas...thanks for the link

-04 CTS-V
-10 Jeep Commander
kpc01 is offline  
post #5 of 5 (permalink) Old 12-22-2005, 03:48 PM Thread Starter
Lifer
 
kpc01's Avatar
 
Join Date: Dec 2002
Location: Oak Point TX
Posts: 1,433
sorry, its a 10w3 sub. Same specs or any different EW?

thanks for the help

-04 CTS-V
-10 Jeep Commander
kpc01 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome