Good Amp for a 10" JL W0? - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 05-20-2005, 11:29 AM Thread Starter
Zar
 
Join Date: Aug 2001
Posts: 602
Good Amp for a 10" JL W0?

Just wondering Thanks!
Zar is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-20-2005, 11:43 AM
bottle baby
 
zcs626's Avatar
 
Join Date: Jul 2004
Location: Carrollton
Posts: 1,812
what are you wanting to spend?
zcs626 is offline  
post #3 of 9 (permalink) Old 05-20-2005, 12:23 PM
Lifer
 
ThreeFingerPete's Avatar
 
Join Date: Sep 2002
Posts: 14,894
4 or 8 ohm?

ThreeFingerPete is offline  
 
post #4 of 9 (permalink) Old 05-20-2005, 02:14 PM Thread Starter
Zar
 
Join Date: Aug 2001
Posts: 602
Im not sure what I wont to spend. I just want something that will push the sub. nice. I have a shity walmart amp someone gave to me. Im guessing 4 ohms? Thats what car speakers usually run at right?
Zar is offline  
post #5 of 9 (permalink) Old 05-20-2005, 02:24 PM
Lifer
 
ThreeFingerPete's Avatar
 
Join Date: Sep 2002
Posts: 14,894
w0's are available in either configuration, which is why i asked.

E2150 if you have a single 4ohm sub.

ThreeFingerPete is offline  
post #6 of 9 (permalink) Old 05-20-2005, 04:03 PM
Time Served
 
Join Date: Nov 2002
Location: SA TX
Posts: 299
Quote:
Originally Posted by OneBadWagon
w0's are available in either configuration, which is why i asked.

E2150 if you have a single 4ohm sub.
Lost me there dude... What brand and specs are these amps you're talking about? Thanks...
Bullitt3055 is offline  
post #7 of 9 (permalink) Old 05-20-2005, 04:48 PM
EW
Procrastination Racing
 
EW's Avatar
 
Join Date: Dec 2000
Location: Bedford, TX
Posts: 9,224
I have not been that impressed with the e2150 on a 4 ohm W0. I would probably use an e1200 or Alpine MRP-M350 even though you're not running a 2 ohm load AND you'd be able to add another woofer later.
EW is offline  
post #8 of 9 (permalink) Old 05-21-2005, 11:17 AM
Punk Ass Newbie
 
Join Date: May 2005
Location: North TX
Posts: 13
jbl 600.1 II would be good amp for 2 WO's just turn amp down lol bout 300 for the amp..

04 GT 4.6 Mineral Gray (SOLD)
87 GT H/B 5.0 Mineral Gray (SOLD)
91 LX Cpe 2.3L RED (SOLD)
2002 Silveraldo 5.3L (SOLD)
XsnyperX is offline  
post #9 of 9 (permalink) Old 05-21-2005, 01:07 PM Thread Starter
Zar
 
Join Date: Aug 2001
Posts: 602
Quote:
Originally Posted by Bullitt3055
Lost me there dude... What brand and specs are these amps you're talking about? Thanks...
Jenson, lol.
Zar is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome