Pics of Subs and Boxes - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 04-21-2005, 12:03 AM Thread Starter
Time Served
 
Join Date: Nov 2002
Location: SA TX
Posts: 299
Pics of Subs and Boxes

Let us see your Sub Boxes or stereo custom install 99-04.

Or email pics to~~~~ >>> [email protected]
Bullitt3055 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 04-21-2005, 01:35 PM Thread Starter
Time Served
 
Join Date: Nov 2002
Location: SA TX
Posts: 299
I just got my amp and subs hooked up sounds great. I routed the speaker wires in parallel for 2ohms using an Alpine M350. Sounds awesome and I was thinking of moving up to a Alpine 501 but I see there's no need.
Now I want to swap my crappy sealed box for a custom ported box tuned to
25 or 26Hz as per speaker specs.

I haven't seen many fotos online with 94-98 or 99-04.

Anybody have a link to where I can see a few setups....?
Bullitt3055 is offline  
post #3 of 11 (permalink) Old 04-21-2005, 04:36 PM
EW
Procrastination Racing
 
EW's Avatar
 
Join Date: Dec 2000
Location: Bedford, TX
Posts: 9,224
You will want to check with your woofer manufacturer and follow their recommended enclosure size and port length & diameter. Many have box designs already made with measurements so you can make a proper enclosure.
EW is offline  
 
post #4 of 11 (permalink) Old 04-21-2005, 07:06 PM
Lifer
 
ThreeFingerPete's Avatar
 
Join Date: Sep 2002
Posts: 14,894
your 12s aren't going to play well to 27hz. tune them to ~31-33 for a good all around sound, or 38hz for a little more bass but less range. really depends on the subwoofer you're using.

ThreeFingerPete is offline  
post #5 of 11 (permalink) Old 04-21-2005, 08:30 PM Thread Starter
Time Served
 
Join Date: Nov 2002
Location: SA TX
Posts: 299
I checked the specs on the subwoofer and it said that the FS(Hz) was 25. Do I go with the 25 or 31-33 in fabricating this enclosure...??
Bullitt3055 is offline  
post #6 of 11 (permalink) Old 04-22-2005, 01:00 PM
Lifer
 
ThreeFingerPete's Avatar
 
Join Date: Sep 2002
Posts: 14,894
Fs: is the free air resonance of the driver, i'd tune it to 31-33, personally.

ThreeFingerPete is offline  
post #7 of 11 (permalink) Old 04-22-2005, 02:53 PM Thread Starter
Time Served
 
Join Date: Nov 2002
Location: SA TX
Posts: 299
Thanks ... Can you give PM me dimensions or ideas to build this ported enclosure.
Bullitt3055 is offline  
post #8 of 11 (permalink) Old 04-23-2005, 02:26 AM
Lifer
 
ThreeFingerPete's Avatar
 
Join Date: Sep 2002
Posts: 14,894
LOL, in the trunk of a mustang with the Junk460 sound, it's gonna be a sonofabitch.

ThreeFingerPete is offline  
post #9 of 11 (permalink) Old 04-23-2005, 08:50 AM
EW
Procrastination Racing
 
EW's Avatar
 
Join Date: Dec 2000
Location: Bedford, TX
Posts: 9,224
If you remove the backseat frame from the car, The largest enclosure that will fit through the opening with the Mach pod inplace is 34" wide x 10" tall x 29"L.
You will not need that much room for a single 12" driver. The specs you are listing are not the recommended size of enclosure or tuning frequency.
EW is offline  
post #10 of 11 (permalink) Old 04-23-2005, 11:27 PM Thread Starter
Time Served
 
Join Date: Nov 2002
Location: SA TX
Posts: 299
It's two 12" Subs that I have. But after having them for a week or so. I bet one in the right box (ported) would be enough. Right now the bass is pretty flippin loud in my car. I had it on in the garage not too loud and the pictures on the wall of my living room were trembling. Pretty cool...

Just got back from Hallsville Speeday near Longview (Bullitt/Mach1 Shootout) and saw how easy it is to remove that Mach460 deck and how to remove the freakin lower rear seat. Just might remove and replace the entire 460 sometime soon.

PS: Oh yeah, bad night for me... 14.01 at 100.8 Did a couple time trials and had to leave early. Dammit I need a supercharger or an NX wet kit....
Bullitt3055 is offline  
post #11 of 11 (permalink) Old 04-26-2005, 04:22 PM
one bad 408 coupe!
 
11secCobra's Avatar
 
Join Date: Mar 2003
Location: carrollton...right next to GB motor speedway
Posts: 1,797
i had 3 W3 10s, and a 1200W amp in mine and it hit HARD
11secCobra is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome