AMP noise - DFWstangs Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-05-2004, 09:38 PM Thread Starter
 
Join Date: Aug 2003
Posts: 1,080
AMP noise

alright i just installed an amp and i get this noise like a buzzing/whining noise. do i have something hooked up wrong or is this something a simple noise filter could fix?
stevinwayne is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-06-2004, 09:36 AM
EW
Procrastination Racing
 
EW's Avatar
 
Join Date: Dec 2000
Location: Bedford, TX
Posts: 9,224
Radio, amp, alt, and battery need to have good grounds. RCA's need to be run away from power wires. There are RCA ground loop isolators and power cable chokes to help eliminate noise. Sometimes grounding the outer RCA connection will help. Sometimes making sure the amp chassis does not touch the body will help. If you have inferior equipment, your fight may be futile.
EW is offline  
post #3 of 3 (permalink) Old 10-08-2004, 06:56 PM
Time Served
 
Join Date: Jul 2003
Posts: 307
Like he said check all your grounds first, then try a groung loop isolator on your RCAs and also you might trying hooking it up with another set of RCAs and maybe another radio to make sure the pre-outs on the deck aren't bad.
Black96StangGT is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DFWstangs Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome